diff options
author | Tim Dettmers <tim.dettmers@gmail.com> | 2022-07-31 20:59:34 -0700 |
---|---|---|
committer | Tim Dettmers <tim.dettmers@gmail.com> | 2022-07-31 20:59:34 -0700 |
commit | 4a6ea7e24b933bf574f7707e1b331ea62f7e7273 (patch) | |
tree | 5f010cc5e24eb1006a5ffbcbc14c827c5fea6d4d /setup.py | |
parent | 28d1e7dc016b72b47dd97ee35094a98d1467cab4 (diff) |
Added adjusted build file.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 22 |
1 files changed, 7 insertions, 15 deletions
@@ -3,28 +3,20 @@ # This source code is licensed under the MIT license found in the # LICENSE file in the root directory of this source tree. import os +import glob from setuptools import setup, find_packages -import os - -def all_libs(directory): - paths = [] - for (path, directories, filenames) in os.walk(directory): - for filename in filenames: - paths.append(os.path.join('..', path, filename)) - return paths +libs = list(glob.glob('./bitsandbytes/libbitsandbytes*.so')) +libs = [os.path.basename(p) for p in libs] +print('libs:', libs) def read(fname): return open(os.path.join(os.path.dirname(__file__), fname)).read() - -version = os.getenv("CUDA_VERSION", "cpu") -prefix = '' if version == 'cpu' else 'cuda' - setup( - name=f"bitsandbytes-{prefix}{version}", - version=f"0.30.2", + name=f"bitsandbytes", + version=f"0.31.0", author="Tim Dettmers", author_email="dettmers@cs.washington.edu", description="8-bit optimizers and matrix multiplication routines.", @@ -35,7 +27,7 @@ setup( entry_points={ "console_scripts": ["debug_cuda = bitsandbytes.debug_cli:cli"], }, - package_data={'': ['libbitsandbytes*.so']}, + package_data={'': libs}, long_description=read('README.md'), long_description_content_type='text/markdown', classifiers=[ |