summaryrefslogtreecommitdiff
path: root/machines/boron.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/boron.nix')
-rw-r--r--machines/boron.nix20
1 files changed, 16 insertions, 4 deletions
diff --git a/machines/boron.nix b/machines/boron.nix
index 6495ecc..6cfa06d 100644
--- a/machines/boron.nix
+++ b/machines/boron.nix
@@ -84,8 +84,6 @@
# Enable CUPS to print documents.
services.printing.enable = true;
- # Enable sound with pipewire.
- sound.enable = true;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
services.pipewire = {
@@ -118,12 +116,26 @@
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
- # vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
- # wget
];
+ programs.winbox = {
+ enable = true;
+ openFirewall = true;
+ };
+ # if winbox doesn't work, these firewall settings worked last time
+ #networking.firewall = {
+ # allowedTCPPorts = [ 80 443 ];
+ # allowedUDPPortRanges = [
+ # {
+ # from = 40000;
+ # to = 50000;
+ # }
+ # ];
+ #};
+
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
+ # vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
# programs.mtr.enable = true;
# programs.gnupg.agent = {
# enable = true;