summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-30 14:55:41 -0400
committerBen Sima <ben@bsima.me>2022-07-30 14:55:41 -0400
commit8f9de177e3cfed26cf9d67fd263d26ba85640eb2 (patch)
tree7c9c98746a55116ca7293a57a6123dcf473daa6a /shell.nix
Initialize dev shell
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..b5c4f45
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+
+ packages = with pkgs; [
+ lolcat
+ (lispPackages_new.sbclWithPackages (p: with p; [
+ asdf
+ swank
+ quickproject
+ alexandria
+ ]))
+ ];
+
+ shellHook = ''
+ echo cl-gemini | figlet | lolcat
+ '';
+
+}