summaryrefslogtreecommitdiff
path: root/Hero/Service.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-06-05 22:27:14 -0700
committerBen Sima <ben@bsima.me>2020-06-05 22:29:30 -0700
commit37062e1ca6c479b7cf773931aa0e797ebcfafe8b (patch)
tree56a2262621f85dc3aabe6983da1da689837b7836 /Hero/Service.nix
parent99c0a806be7fa502394cc3b3634ce7eb43f97024 (diff)
Add user datatype to keep
I also restructured some types so that I could grab a handle on the keep to close it on shutdown, otherwise the database would be locked and I can't do anything about it. This might mean I have to delete and start the database from scratch when I deploy, but that's okay because I haven't stored anything yet. I also renamed some stuff like 'deck' and 'beam' just for fun. I could make these into more general interfaces like I always planned to. Also I haven't really tested this yet, so... next commit will implement the user login.
Diffstat (limited to 'Hero/Service.nix')
-rw-r--r--Hero/Service.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/Hero/Service.nix b/Hero/Service.nix
index 8bad6d7..a3c6bd5 100644
--- a/Hero/Service.nix
+++ b/Hero/Service.nix
@@ -18,16 +18,16 @@ in
The port on which herocomics-server will listen for incoming HTTP traffic.
'';
};
- dataDir = lib.mkOption {
+ keep = lib.mkOption {
type = lib.types.path;
default = "/var/lib/hero";
description = "herocomics-server database directory";
};
- server = lib.mkOption {
+ deck = lib.mkOption {
type = lib.types.package;
description = "herocomics-server package to use";
};
- client = lib.mkOption {
+ beam = lib.mkOption {
type = lib.types.package;
description = "herocomics-client package to use";
};
@@ -42,10 +42,10 @@ in
};
config = lib.mkIf cfg.enable {
systemd.services.herocomics = {
- path = [ cfg.server ];
+ path = [ cfg.deck ];
wantedBy = [ "multi-user.target" ];
script = ''
- ${cfg.server}/bin/mmc
+ ${cfg.deck}/bin/mmc
'';
description = ''
Hero Comics app server
@@ -53,9 +53,9 @@ in
serviceConfig = {
KillSignal = "INT";
Environment = [
- "HERO_CLIENT=${cfg.client}/static"
+ "HERO_BEAM=${cfg.beam}/static"
"HERO_PORT=${toString cfg.port}"
- "HERO_DATA_DIR=${cfg.dataDir}"
+ "HERO_KEEP=${cfg.keep}"
];
Type = "simple";
Restart = "on-abort";