summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-11 14:15:38 -0800
committerBen Sima <ben@bsima.me>2019-02-11 14:16:41 -0800
commit9ada7b8736936c632074bd4c1165449d00a588ec (patch)
tree56eeeb200c35219d11dd4b813cfeaa632985e6cc /configuration.nix
parent39a6bfa2ab6f126f6b3f8891348bc24953bdce7f (diff)
Add home and tv subdomains
DNS records were also set. https://todo.sr.ht/~ben/biz/7
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix34
1 files changed, 7 insertions, 27 deletions
diff --git a/configuration.nix b/configuration.nix
index 1828d22..775bc99 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,5 +1,8 @@
{ ... }:
+let
+ bensIp = "68.107.97.20";
+in
{
nixpkgs.config.packageOverrides = pkgs: {
ibb = import ./ibb/default.nix {};
@@ -18,33 +21,10 @@
recommendedProxySettings = true;
recommendedTlsSettings = true;
virtualHosts = {
- "simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:8000";
- };
- };
- };
- "dev.simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:3000";
- };
- };
- };
- "hero.simatime.com" = {
- #forceSSL = true;
- #enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://68.107.97.20:3001";
- };
- };
- };
+ "simatime.com".locations."/".proxyPass = "http://${bensIp}:8000";
+ "dev.simatime.com".locations."/".proxyPass = "http://${bensIp}:3000";
+ "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
+ "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
"influencedbybooks.com" = {
forceSSL = true;
enableACME = true;