summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-16 20:51:58 -0800
committerBen Sima <ben@bsima.me>2019-02-16 20:51:58 -0800
commitcf5b024e189cb4ed85f80b521cf9e0e5dc5b5070 (patch)
treef579a2ff069862856e6a1667426769c165aaa079 /configuration.nix
parent225f2c575d18f080daa82d634af7f1fde4f03809 (diff)
Make port configurable
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/configuration.nix b/configuration.nix
index 775bc99..adf90d3 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -2,6 +2,7 @@
let
bensIp = "68.107.97.20";
+ ibbPort = "3000";
in
{
nixpkgs.config.packageOverrides = pkgs: {
@@ -12,7 +13,10 @@ in
services = {
- ibb.enable = true;
+ ibb = {
+ enable = true;
+ port = ibbPort;
+ };
nginx = {
enable = true;
@@ -22,7 +26,7 @@ in
recommendedTlsSettings = true;
virtualHosts = {
"simatime.com".locations."/".proxyPass = "http://${bensIp}:8000";
- "dev.simatime.com".locations."/".proxyPass = "http://${bensIp}:3000";
+ "dev.simatime.com".locations."/".proxyPass = "http://${bensIp}:${ibbPort}";
"hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
"tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
"influencedbybooks.com" = {
@@ -30,7 +34,7 @@ in
enableACME = true;
locations = {
"/" = {
- proxyPass = "http://localhost:3000";
+ proxyPass = "http://localhost:${ibbPort}";
};
};
};