summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/openai-python.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/openai-python.nix')
-rw-r--r--Omni/Bild/Deps/openai-python.nix99
1 files changed, 99 insertions, 0 deletions
diff --git a/Omni/Bild/Deps/openai-python.nix b/Omni/Bild/Deps/openai-python.nix
new file mode 100644
index 0000000..79db11c
--- /dev/null
+++ b/Omni/Bild/Deps/openai-python.nix
@@ -0,0 +1,99 @@
+{
+ lib,
+ buildPythonPackage,
+ pythonOlder,
+ # build-system
+ hatchling,
+ hatch-fancy-pypi-readme,
+ # dependencies
+ anyio,
+ distro,
+ httpx,
+ jiter,
+ pydantic,
+ sniffio,
+ tqdm,
+ typing-extensions,
+ numpy,
+ pandas,
+ pandas-stubs,
+ # check deps
+ pytestCheckHook,
+ dirty-equals,
+ inline-snapshot,
+ nest-asyncio,
+ pytest-asyncio,
+ pytest-mock,
+ respx,
+ sources,
+}:
+buildPythonPackage rec {
+ pname = "openai";
+ version = sources.openai-python.version;
+ pyproject = true;
+
+ disabled = pythonOlder "3.8";
+
+ src = sources.openai-python;
+
+ build-system = [
+ hatchling
+ hatch-fancy-pypi-readme
+ ];
+
+ dependencies = [
+ anyio
+ distro
+ httpx
+ jiter
+ pydantic
+ sniffio
+ tqdm
+ typing-extensions
+ ];
+
+ optional-dependencies = {
+ datalib = [
+ numpy
+ pandas
+ pandas-stubs
+ ];
+ };
+
+ pythonImportsCheck = ["openai"];
+
+ nativeCheckInputs = [
+ pytestCheckHook
+ dirty-equals
+ inline-snapshot
+ nest-asyncio
+ pytest-asyncio
+ pytest-mock
+ respx
+ ];
+
+ pytestFlagsArray = [
+ "-W"
+ "ignore::DeprecationWarning"
+ ];
+
+ disabledTests = [
+ # Tests make network requests
+ "test_copy_build_request"
+ "test_basic_attribute_access_works"
+ ];
+
+ disabledTestPaths = [
+ # Test makes network requests
+ "tests/api_resources"
+ ];
+
+ meta = with lib; {
+ description = "Python client library for the OpenAI API";
+ homepage = "https://github.com/openai/openai-python";
+ changelog = "https://github.com/openai/openai-python/releases/tag/v${version}";
+ license = licenses.mit;
+ maintainers = with maintainers; [malo];
+ mainProgram = "openai";
+ };
+}