summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/outlines.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/outlines.nix')
-rw-r--r--Omni/Bild/Deps/outlines.nix23
1 files changed, 18 insertions, 5 deletions
diff --git a/Omni/Bild/Deps/outlines.nix b/Omni/Bild/Deps/outlines.nix
index 29ef41b..6426c15 100644
--- a/Omni/Bild/Deps/outlines.nix
+++ b/Omni/Bild/Deps/outlines.nix
@@ -1,6 +1,19 @@
-{ lib, sources, buildPythonPackage, interegular, jinja2, lark, numpy, perscache
-, pillow, pydantic, regex, scipy, tenacity, torch }:
-
+{
+ lib,
+ sources,
+ buildPythonPackage,
+ interegular,
+ jinja2,
+ lark,
+ numpy,
+ perscache,
+ pillow,
+ pydantic,
+ regex,
+ scipy,
+ tenacity,
+ torch,
+}:
buildPythonPackage rec {
pname = "outlines";
version = sources.outlines.rev;
@@ -23,12 +36,12 @@ buildPythonPackage rec {
];
doCheck = false; # no tests currently
- pythonImportsCheck = [ "outlines" ];
+ pythonImportsCheck = ["outlines"];
meta = with lib; {
description = "Probabilistic Generative Model Programming";
homepage = "https://github.com/normal-computing/outlines";
license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
};
}