summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/perscache.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Deps/perscache.nix')
-rw-r--r--Omni/Bild/Deps/perscache.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/Omni/Bild/Deps/perscache.nix b/Omni/Bild/Deps/perscache.nix
index 508a261..889f91c 100644
--- a/Omni/Bild/Deps/perscache.nix
+++ b/Omni/Bild/Deps/perscache.nix
@@ -1,16 +1,23 @@
-{ lib, sources, buildPythonPackage, beartype, cloudpickle, icontract, pbr }:
-
+{
+ lib,
+ sources,
+ buildPythonPackage,
+ beartype,
+ cloudpickle,
+ icontract,
+ pbr,
+}:
buildPythonPackage rec {
pname = "perscache";
version = sources.perscache.rev;
src = sources.perscache;
- propagatedBuildInputs = [ beartype cloudpickle icontract pbr ];
+ propagatedBuildInputs = [beartype cloudpickle icontract pbr];
PBR_VERSION = version;
doCheck = false; # no tests currently
- pythonImportsCheck = [ "perscache" ];
+ pythonImportsCheck = ["perscache"];
meta = with lib; {
description = ''
@@ -20,6 +27,6 @@ buildPythonPackage rec {
'';
homepage = "https://github.com/leshchenko1979/perscache";
license = licenses.mit;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
};
}