summaryrefslogtreecommitdiff
path: root/Omni/Bild/Functions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Bild/Functions.nix')
-rw-r--r--Omni/Bild/Functions.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/Omni/Bild/Functions.nix b/Omni/Bild/Functions.nix
index 8b87f86..2a40da2 100644
--- a/Omni/Bild/Functions.nix
+++ b/Omni/Bild/Functions.nix
@@ -10,24 +10,25 @@ _: super: {
# rules. This will fail if build steps have changed, or if no build
# rules are available upstream.
overrideSource = depName:
- if super ? "${depName}" && super.${depName} ? overrideAttrs then
+ if super ? "${depName}" && super.${depName} ? overrideAttrs
+ then
super.${depName}.overrideAttrs (attrs:
- attrs // rec {
+ attrs
+ // rec {
version =
super.sources.${depName}.version or super.sources.${depName}.rev;
src = super.sources.${depName};
})
- else
- null;
+ else null;
# Simply override the 'src' attr on a drv. This is meant to be a simpler
# alternative to 'overrideSource' above. In an overlay, use it like:
# mypkg = super.overrideSrc super.mypkg super.sources.mypkg;
overrideSrc = dep: src:
dep.overrideAttrs (attrs:
- attrs // {
+ attrs
+ // {
version = src.version or src.rev;
src = src;
});
}
-