summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Omni/Cloud/Web.nix')
-rw-r--r--Omni/Cloud/Web.nix23
1 files changed, 2 insertions, 21 deletions
diff --git a/Omni/Cloud/Web.nix b/Omni/Cloud/Web.nix
index 84f87d4..df62aa3 100644
--- a/Omni/Cloud/Web.nix
+++ b/Omni/Cloud/Web.nix
@@ -105,12 +105,10 @@ in {
virtualHosts = {
${rootDomain} = {
+ serverName = rootDomain;
forceSSL = true;
enableACME = true;
locations = {
- # the nginx/cgit module puts a '/' at the end of 'location', so we need to
- # redirect '/git' to '/git/'
- "/git".return = "301 https://$host/git/";
# nostr nip-5 verification
"/.well-known/nostr.json".return = "200 '${
builtins.toJSON {
@@ -134,24 +132,6 @@ in {
};
};
- # these are for xmpp, not sure if they are necessary but they seem to be?
- "conference.${rootDomain}" = {
- forceSSL = true;
- useACMEHost = rootDomain;
- locations."/" = {
- root = "/var/web/simatime.com";
- extraConfig = "autoindex on;";
- };
- };
- "upload.${rootDomain}" = {
- forceSSL = true;
- useACMEHost = rootDomain;
- locations."/" = {
- root = "/var/web/simatime.com";
- extraConfig = "autoindex on;";
- };
- };
-
"bsima.me" = {
locations."/" = {
root = "/var/web/ben";
@@ -303,6 +283,7 @@ in {
"m.youtube"
"sd"
"gerrit"
+ "git"
# xmpp stuff
"upload"
"conference"