summaryrefslogtreecommitdiff
path: root/Que/Site.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Que/Site.nix')
-rw-r--r--Que/Site.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/Que/Site.nix b/Que/Site.nix
deleted file mode 100644
index ba2eeb2..0000000
--- a/Que/Site.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-
-
-let
- cfg = config.services.que-website;
- static = pkgs.stdenv.mkDerivation {
- src = ./.;
- name = "que-website-static";
- installPhase = ''
- mkdir -p $out
- cp ${./Apidocs.md} $out/Apidocs.md
- cp ${./Index.md} $out/Index.md
- cp ${./Quescripts.md} $out/Quescripts.md
- cp ${./Style.css} $out/Style.css
- cp ${./Tutorial.md} $out/Tutorial.md
- cp ${./Client.py} $out/Client.py
- '';
- };
-in
-{
- options.services.que-website = {
- enable = lib.mkEnableOption "Enable the que-website service";
- namespace = lib.mkOption {
- type = lib.types.str;
- default = "_";
- description = ''
- The que namespace on which que-website will broadcast.
- '';
- };
- package = lib.mkOption {
- type = lib.types.package;
- description = "que-website package to use";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.que-website = {
- path = [ cfg.package pkgs.pandoc ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.package}/bin/que-website ${static} ${cfg.namespace}
- '';
- description = ''
- Que website server
- '';
- serviceConfig = {
- User = "root";
- Environment = "HOME=/root";
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- };
-}