{ pkgs, ... }:

{
  services = {
    gitolite = {
      enable = true;
      enableGitAnnex = true;
      # TODO: change this to /var/lib/gitolite?
      dataDir = "/srv/git";
      user = "git";
      group = "git";
      extraGitoliteRc = ''
        $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
      '';
      adminPubkey = builtins.readFile ../keys/ben.pub;
    };
  };
}