{ nixpkgs }:
with nixpkgs;
let
  ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp: with hp; [
    hinotify

    mongoDB
    mtl
    protolude
    text
    transformers
  ]);
  entrypoint = "Duree";
in
stdenv.mkDerivation rec {
  name = "duree";
  version = "0";
  src = ../.;
  nativeBuildInputs = [
    ghc
  ];
  strictDeps = true;
  buildPhase = ''
    ${ghc}/bin/ghc \
      -iapex -ilore \
      -main-is ${entrypoint} --make apex/${entrypoint}.hs \
      -o bild/${name}
  '';
  installPhase = ''
    mkdir -p $out/bin
    cp bild/${name} $out/bin/${name}
  '';
}