diff options
author | Ben Sima <ben@bsima.me> | 2018-11-10 07:58:01 -0800 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2018-11-10 07:58:01 -0800 |
commit | f64aedf9d82062df9decfcc71583b83c2aa34116 (patch) | |
tree | 3767c3000b033d8133424a4257a140646a6d6915 /common.nix | |
parent | 7283ffd5916bfc7f8d935604efe2741dd6813bab (diff) |
Implement afew
Diffstat (limited to 'common.nix')
-rw-r--r-- | common.nix | 65 |
1 files changed, 64 insertions, 1 deletions
@@ -282,7 +282,16 @@ in msmtp-queue -r mbsync --all ''; - postNew = builtins.readFile ./notmuch-hook.sh; + postNew = '' + notmuch tag -inbox +haskell -- to:haskell-cafe@haskell.org + notmuch tag -inbox +clojure -- to:clojure@googlegroups.com + notmuch tag -inbox +ai -- to:scikit-learn@python.org OR to:tensorflow.org + notmuch tag -inbox +bitcoin -- to:bitcoin-dev@lists.linuxfoundation.org OR to:bitcoin-discuss@lists.linuxfoundation.org + notmuch tag -inbox +diybio -- to:diybio@googlegroups.com + notmuch tag -inbox +meetups -- from:meetup.com + afew -tn + ''; + }; extraConfig = { search = { @@ -291,6 +300,60 @@ in }; }; + afew = { + enable = true; + extraConfig = '' + [ArchiveSentMailsFilter] + + [SpamFilter] + spam_tag = spam + + # This filter looks for the List-Id header, and if it finds it, adds a + # tag lists and a tag named lists/<list-id>. + [ListMailsFilter] + + [Filter.0] + message = mobile todos + query = 'from:ben@bsima.me AND to:ben@bsima.me AND subject:TODO' + tags = +todo;-inbox;+unread + + [Filter.1] + message = logwatch + query = subject:Logwatch + tags = +logwatch;-new;-inbox + + [Filter.2] + message = newsletters + query = + from:the-morning-paper@onelanday.co.uk OR + from:newsletter@fightaging.org OR + from:newsletter@fightaging.org or + subject:'The Reading List Email*' OR + from:info@haskellweekly.news OR + from:kale@hackernewsletter.com OR + from:newsletter@farnamstreetblog.com + tags = -unread +deals + + [Filter.3] + message = job emails + query = + from:alist.co OR + from:angel.co OR + from:stackoverflow.com OR + from:stackoverflow.email OR + from:cdmtechnology.com OR + subject:job + tags = +jobs;-inbox + + [Filter.4] + message = github + query = from:github.com + tags = +github;-inbox + + [InboxFilter] + ''; + }; + mbsync = { enable = true; }; |