diff options
author | Ben Sima <ben@bsima.me> | 2020-07-06 19:51:46 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2020-07-07 11:32:23 -0700 |
commit | 38a6aae875f8eeb28e7774adcf319fd52178b900 (patch) | |
tree | d0a35d9a9e0a022fe24b4a958d7ec35e78fca5ba /darwin.nix | |
parent | 30a45d8aa3f346d77cbf71a0d1444150b2f763a9 (diff) |
fixes for mac build
Diffstat (limited to 'darwin.nix')
-rw-r--r-- | darwin.nix | 41 |
1 files changed, 40 insertions, 1 deletions
@@ -2,8 +2,47 @@ let homedir = builtins.getEnv "HOME"; + gitCommitTemplate = ./lib/git-commit-template; + gpgid = "D09299626FA78AF8"; in { - imports = [ ./common.nix ]; + imports = [ ./lib/common.nix ]; home.sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH"; + programs = { + + git = { + enable = true; + userName = "Ben Sima"; + userEmail = "ben@bsima.me"; + ignores = [ "*~" "*.swp" ]; + package = pkgs.gitAndTools.gitFull; + signing = { + key = gpgid; + signByDefault = false; + }; + aliases = { + authors = "shortlog -s -n"; + }; + extraConfig = '' + [push] + default = simple + + [commit] + template = ${gitCommitTemplate} + + [sendemail] + smtpuser = ben@bsima.me + smptserverport = 587 + smptserver = mail.bsima.me + chainreplyto = false + composeencoding = UTF-8 + ''; + }; + + emacs = { + enable = true; + extraPackages = epkgs: import ./lib/emacs-packages.nix { inherit epkgs; }; + }; + + }; } |