diff options
author | Ben Sima <bsima@groq.com> | 2019-06-13 10:24:53 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2019-07-09 15:49:50 -0700 |
commit | 270c52cf6f06b590e6c3fc08512fac4d8a80c064 (patch) | |
tree | 305ac0f5dbc12ae3799ad18a5633878fe609c0c6 /groq.nix | |
parent | f2bce08b9412b0b50d3d7af8dff7903b40f13bff (diff) |
add groq email
Diffstat (limited to 'groq.nix')
-rw-r--r-- | groq.nix | 40 |
1 files changed, 40 insertions, 0 deletions
@@ -7,6 +7,30 @@ in imports = [ ./common.nix ]; + + accounts = { + email = { + maildirBasePath = "mail"; + accounts = { + "groq" = { + primary = true; + flavor = "gmail.com"; + realName = "Ben Sima"; + address = "bsima@groq.com"; + userName = "bsima@groq.com"; + mbsync = { + enable = true; + create = "both"; + expunge = "none"; + }; + notmuch.enable = true; + msmtp.enable = true; + passwordCommand = "secret-tool lookup email bsima@groq.io"; + }; + }; + }; + }; + programs = { emacs = { enable = true; @@ -28,5 +52,21 @@ in ''; }; + mbsync.enable = true; + msmtp.enable = true; + + notmuch = { + enable = true; + new.tags = ["new"]; + hooks = {}; + extraConfig.search.exclude_tags = "deleted;spam;"; + }; + + alot = { + enable = true; + extraConfig = '' + theme = solarized_light + ''; + }; }; } |