summaryrefslogtreecommitdiff
path: root/lib/email.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-01-20 17:05:16 -0500
committerBen Sima <ben@bsima.me>2023-01-20 17:05:16 -0500
commit5250dc6adab5961561ceec808b5bba778beecc83 (patch)
tree7d43a4d78f43ea2ea3d6945f938a9adf18459d01 /lib/email.nix
parent66d3268b80620ae1236cbfb7cbf07543061be607 (diff)
setup afew MailMover (i think)
Change-Id: Ia9b38360f359f1c7234fc894fbfc8d97d426ce45
Diffstat (limited to 'lib/email.nix')
-rw-r--r--lib/email.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/email.nix b/lib/email.nix
index e874dd6..7f477e3 100644
--- a/lib/email.nix
+++ b/lib/email.nix
@@ -1,4 +1,4 @@
-{ pkgs, ... }:
+{ pkgs, lib, ... }:
let
gpgid = "D09299626FA78AF8";
@@ -48,9 +48,13 @@ in
programs = {
notmuch = {
enable = true;
- new.tags = [ "new" ];
+ new.tags = [ "unread" "inbox" ];
hooks = {
- postNew = "${pkgs.afew}/bin/afew -tn && ${pkgs.afew}/bin/afew -t tag:inbox";
+ postNew = lib.strings.concatStringsSep " && " [
+ "${pkgs.afew}/bin/afew --tag --new"
+ "${pkgs.afew}/bin/afew --tag tag:inbox"
+ "${pkgs.afew}/bin/afew --move-mail"
+ ];
};
extraConfig = {
search = {