summaryrefslogtreecommitdiff
path: root/lib/ssh.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-02-24 16:40:51 -0500
committerBen Sima <ben@bsima.me>2025-02-24 16:40:51 -0500
commitd0ba514a28d2af43d3bbfafac30b8c2f1a01a814 (patch)
treeec53f15a9bc7c2b049826c5dc10070367e395cc3 /lib/ssh.nix
parent3b61ae429f3bc75ddfe56d1eacb024c7a5ff469a (diff)
fixup my ssh stuff, forward gpg agent to beryl
Diffstat (limited to 'lib/ssh.nix')
-rw-r--r--lib/ssh.nix62
1 files changed, 4 insertions, 58 deletions
diff --git a/lib/ssh.nix b/lib/ssh.nix
index 013e727..6446a63 100644
--- a/lib/ssh.nix
+++ b/lib/ssh.nix
@@ -7,68 +7,14 @@ in {
controlMaster = "auto";
enable = true;
forwardAgent = true;
- extraConfig = ''
- # this never works, i just get a warning when i ssh
- # RemoteForward %d/.gnupg/S.gpg-agent ''${HOME}/.gnupg/S.gpg-agent.extra
- '';
matchBlocks = {
- # groq
- "bsima" = {
- hostname = "bsima"; # must be on vpn
- user = "bsima";
- identityFile = [ "${homedir}/.ssh/groq" ];
- identitiesOnly = true;
- forwardAgent = true;
+ "beryllium" = {
+ hostname = "beryllium";
extraOptions = {
- #"RemoteCommand" = "tmux -CC new -As0";
- "RequestTTY" = "force";
+ "RemoteForward" = "/run/user/1000/gnupg/S.gpg-agent /run/user/1000/gnupg/S.gpg-agent.extra";
+ "StreamLocalBindUnlink" = "yes";
};
};
-
- # simatime
- "sabten" = {
- hostname = "142.93.81.26";
- user = "root";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "serval.simatime.com" = {
- hostname = "serval.simatime.com";
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- #"simatime.com" = {
- # hostname = "simatime.com";
- # user = "git";
- # identitiesOnly = true;
- # extraOptions = {
- # # PKCS11Provider = "/run/current-system/sw/lib/opensc-pkcs11.so";
- # };
- #};
- "gerrit.simatime.com" = {
- hostname = "gerrit.simatime.com";
- user = "bsima";
- identityFile = [ "${homedir}/.ssh/gerrit.simatime.com" ];
- identitiesOnly = true;
- };
- "lithium" = {
- hostname = "192.168.1.9";
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- #"dev.simatime.com" = {
- # user = "ben";
- # identityFile = [ "${homedir}/.ssh/id_rsa" ];
- # identitiesOnly = true;
- #};
- "git.platonic.systems" = {
- hostname = "git.platonic.systems";
- user = "git";
- identityFile = [ "${homedir}/.ssh/platonic.systems" ];
- identitiesOnly = true;
- };
};
};
}