diff options
author | Ben Sima <ben@bsima.me> | 2019-07-10 11:03:55 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2019-07-10 11:03:55 -0700 |
commit | 6b64f05a4063d09d6b11b13b5496c021c8c69460 (patch) | |
tree | df63be6a89931457ee3f66f4c5a4d15c08fb88e2 /linux.nix | |
parent | bf1825677bf32694235c337093b311fa080dded6 (diff) |
move git config out of common.nix
Diffstat (limited to 'linux.nix')
-rw-r--r-- | linux.nix | 31 |
1 files changed, 31 insertions, 0 deletions
@@ -2,6 +2,8 @@ let homedir = builtins.getEnv "HOME"; + gitCommitTemplate = ./git-commit-template; + gpgid = "D09299626FA78AF8"; cmdtree = pkgs.stdenv.mkDerivation { name = "cmdtree"; src = fetchGit { @@ -358,6 +360,35 @@ in }; programs = { + git = { + enable = true; + userName = "Ben Sima"; + userEmail = "ben@bsima.me"; + ignores = [ "*~" "*.swp" ]; + package = pkgs.gitAndTools.gitFull; + signing = { + key = gpgid; + signByDefault = false; + }; + aliases = { + authors = "shortlog -s -n"; + }; + extraConfig = '' + [push] + default = simple + + [commit] + template = ${gitCommitTemplate} + + [sendemail] + smtpuser = ben@bsima.me + smptserverport = 587 + smptserver = mail.bsima.me + chainreplyto = false + composeencoding = UTF-8 + ''; + }; + emacs = { enable = true; extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; }; |