diff options
author | Ben Sima <ben@bsima.me> | 2019-07-07 15:47:28 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2019-07-07 15:47:28 -0700 |
commit | 72400bb76677ae44236ae9712d31de4558383675 (patch) | |
tree | 6035d17d9e82548d7092c861661ff3fb3bd1103d /linux.nix | |
parent | c05ed3064fc3fabe4691cd35483a1c098a2b7aa6 (diff) |
polybar mem module
Diffstat (limited to 'linux.nix')
-rw-r--r-- | linux.nix | 10 |
1 files changed, 9 insertions, 1 deletions
@@ -69,6 +69,7 @@ in keybase.enable = true; polybar = { + # https://github.com/0x746866/dots/blob/master/polybar/config enable = true; config = { "bar/top" = { @@ -81,7 +82,7 @@ in module-margin = 1; modules-center = "date"; modules-left = "volume-bar"; - modules-right = [ "battery" "cpu" "temp" ]; + modules-right = [ "battery" "cpu" "mem" "temp" ]; monitor = "\${env:MONITOR:HDMI-1}"; monitor-fallback = "\${env:MONITOR:eDP-1}"; radius = 0; @@ -185,6 +186,13 @@ in label-warn-padding = 1; label-warn-foreground = colors.${theme}.highlight; }; + "module/mem" = { + type = "internal/memory"; + interval = 3; + format = "<label>"; + label-padding = 1; + label = " %percentage_used%%"; + }; }; script = '' #!/usr/bin/env sh |