diff options
author | Ben Sima <ben@bsima.me> | 2019-03-22 12:16:49 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2019-03-22 12:19:16 -0700 |
commit | 9ece05be716c92b451ff84952f389f1ca8d30abd (patch) | |
tree | 2583d02aa17c15d3ddfeb858eac93ebf9323c357 /linux.nix | |
parent | 427948ea63bc17cf001e7770d9aa321c5696380d (diff) |
Trying to fix xterm UTF8 encoding
This makes it slightly better but doesn't seem to totally fix it. Every time I
open a terminal, I have to ctrl+right-click and select "UTF-8 Encoding". Not
sure how to make this setting persistent.
Diffstat (limited to 'linux.nix')
-rw-r--r-- | linux.nix | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -9,11 +9,12 @@ in xresources = { properties = { - "XTerm*font" = "*-fixed-*-*-*-*-*"; - "XTerm*faceName" = "mononoki"; + "XTerm*font" = "-*-terminus-medium-r-normal--18-*-*-*-*-*-iso10646-1"; + "XTerm*faceName" = "Terminus"; "XTerm*faceSize" = "10"; "XTerm*termName" = "xterm-256color"; "XTerm*metaSendsEscape" = true; + "XTerm*utf8" = true; }; extraConfig = builtins.readFile(solarized-xresources + "/Xresources.light"); }; |