diff options
author | Ben Sima <ben@bsima.me> | 2018-05-31 14:17:07 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2018-05-31 14:17:07 -0700 |
commit | 9c77a5ff83a7b9ffb87b1087d1f27cc534ceaeb4 (patch) | |
tree | 704314076593d2b527e4ee0f02cd59ece1486f46 /vim.nix | |
parent | d6ee0e228470a3f13dc17f465da770e940f6c4ea (diff) |
Polybar and stuff
Diffstat (limited to 'vim.nix')
-rw-r--r-- | vim.nix | 34 |
1 files changed, 24 insertions, 10 deletions
@@ -1,3 +1,17 @@ +{ pkgs, vimUtils, fetchFromGitHub }: + +let + vim-sexp = vimUtils.buildVimPluginFrom2Nix { + name = "elm.vim-2017-07-09"; + src = fetchFromGitHub { + owner = "guns"; + repo = "vim-sexp"; + rev = "12292941903d9ac8151513189d2007e1ccfc95f0"; + sha256 = "1mfqbmrbqgnsc34pmcsrc0c5zvgxhhnw4hx4g5wbssfk1ddyx6y0"; + }; + dependencies = []; + }; +in { enable = true; plugins = [ @@ -12,16 +26,6 @@ tabstop = 4; }; extraConfig = '' - " Auto-switch theme - let hour = strftime("%H") - if 6 <= hour && hour < 18 - set background=light - else - set background=dark - endif - let g:solarized_termcolors=256 - colorscheme solarized - " set cuc cul " Crosshair set cc=80 " 80 column lines set linebreak " Break lines at word (requires Wrap lines) @@ -34,5 +38,15 @@ set smartindent " Enable smart-indent imap fd <Esc> set mouse=a + "" + "" Auto-switch theme + let hour = strftime("%H") + if 6 <= hour && hour < 18 + set background=light + else + set background=dark + endif + let g:solarized_termcolors=256 + colorscheme solarized ''; } |