diff options
Diffstat (limited to 'darwin.nix')
-rw-r--r-- | darwin.nix | 41 |
1 files changed, 40 insertions, 1 deletions
@@ -2,8 +2,47 @@ let homedir = builtins.getEnv "HOME"; + gitCommitTemplate = ./lib/git-commit-template; + gpgid = "D09299626FA78AF8"; in { - imports = [ ./common.nix ]; + imports = [ ./lib/common.nix ]; home.sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH"; + programs = { + + git = { + enable = true; + userName = "Ben Sima"; + userEmail = "ben@bsima.me"; + ignores = [ "*~" "*.swp" ]; + package = pkgs.gitAndTools.gitFull; + signing = { + key = gpgid; + signByDefault = false; + }; + aliases = { + authors = "shortlog -s -n"; + }; + extraConfig = '' + [push] + default = simple + + [commit] + template = ${gitCommitTemplate} + + [sendemail] + smtpuser = ben@bsima.me + smptserverport = 587 + smptserver = mail.bsima.me + chainreplyto = false + composeencoding = UTF-8 + ''; + }; + + emacs = { + enable = true; + extraPackages = epkgs: import ./lib/emacs-packages.nix { inherit epkgs; }; + }; + + }; } |