diff options
Diffstat (limited to 'groq.nix')
-rw-r--r-- | groq.nix | 40 |
1 files changed, 40 insertions, 0 deletions
@@ -7,6 +7,30 @@ in imports = [ ./common.nix ]; + + accounts = { + email = { + maildirBasePath = "mail"; + accounts = { + "groq" = { + primary = true; + flavor = "gmail.com"; + realName = "Ben Sima"; + address = "bsima@groq.com"; + userName = "bsima@groq.com"; + mbsync = { + enable = true; + create = "both"; + expunge = "none"; + }; + notmuch.enable = true; + msmtp.enable = true; + passwordCommand = "secret-tool lookup email bsima@groq.io"; + }; + }; + }; + }; + programs = { emacs = { enable = true; @@ -28,5 +52,21 @@ in ''; }; + mbsync.enable = true; + msmtp.enable = true; + + notmuch = { + enable = true; + new.tags = ["new"]; + hooks = {}; + extraConfig.search.exclude_tags = "deleted;spam;"; + }; + + alot = { + enable = true; + extraConfig = '' + theme = solarized_light + ''; + }; }; } |