summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-05-11 14:28:09 -0400
committerBen Sima <ben@bsima.me>2024-05-20 22:15:49 -0400
commitcceefa62d147594d43478e398bbaa9c630670935 (patch)
tree458b468f271c156a7e91944e58d2861afd5e1dab /Biz/Bild/Deps.nix
parentdd0bc9610cf0e6842f5d5ac67a73f2fd6f4eba2f (diff)
Setup ollama API service
This superceedes exllama and tabbyAPI which I could never get working fully. Unfortunately I had to switch to NixOS unstable to get all the Go builder stuff to work, so this is a cause of yet another version drift, but I guess it's inevitable and I should just learn to mitigate it with my nixpkgs shenanigans.
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 8f44dde..8bf2272 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -31,4 +31,6 @@ _self: super:
};
nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix { };
+
+ ollama = super.callPackage ./Deps/ollama.nix { acceleration = "cuda"; };
}