summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/guile-opengl.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Bild/Deps/guile-opengl.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Bild/Deps/guile-opengl.nix')
-rw-r--r--Biz/Bild/Deps/guile-opengl.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild/Deps/guile-opengl.nix b/Biz/Bild/Deps/guile-opengl.nix
index d547042..af01082 100644
--- a/Biz/Bild/Deps/guile-opengl.nix
+++ b/Biz/Bild/Deps/guile-opengl.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, pkgconfig, guile, libGL, libGLU, freeglut }:
+{ stdenv, lib, fetchurl, pkg-config, guile, libGL, libGLU, freeglut }:
let
name = "guile-opengl-${version}";
@@ -20,7 +20,7 @@ in stdenv.mkDerivation {
--replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
'';
- nativeBuildInputs = [ pkgconfig guile libGL libGLU freeglut ];
+ nativeBuildInputs = [ pkg-config guile libGL libGLU freeglut ];
meta = with lib; {
description = "Guile bindings for the OpenGL graphics API";