summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/lion-pytorch.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Bild/Deps/lion-pytorch.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Bild/Deps/lion-pytorch.nix')
-rw-r--r--Biz/Bild/Deps/lion-pytorch.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/Biz/Bild/Deps/lion-pytorch.nix b/Biz/Bild/Deps/lion-pytorch.nix
index e23011a..7b06e78 100644
--- a/Biz/Bild/Deps/lion-pytorch.nix
+++ b/Biz/Bild/Deps/lion-pytorch.nix
@@ -1,9 +1,4 @@
-{ lib
-, buildPythonPackage
-, pythonOlder
-, fetchFromGitHub
-, torch
-}:
+{ lib, buildPythonPackage, pythonOlder, fetchFromGitHub, torch }:
buildPythonPackage rec {
pname = "lion-pytorch";
@@ -21,7 +16,7 @@ buildPythonPackage rec {
propagatedBuildInputs = [ torch ];
pythonImportsCheck = [ "lion_pytorch" ];
- doCheck = false; # no tests currently
+ doCheck = false; # no tests currently
meta = with lib; {
description = "Optimizer tuned by Google Brain using genetic algorithms";