summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/llama-cpp.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Bild/Deps/llama-cpp.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Bild/Deps/llama-cpp.nix')
-rw-r--r--Biz/Bild/Deps/llama-cpp.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/Biz/Bild/Deps/llama-cpp.nix b/Biz/Bild/Deps/llama-cpp.nix
index b247252..2e2aae7 100644
--- a/Biz/Bild/Deps/llama-cpp.nix
+++ b/Biz/Bild/Deps/llama-cpp.nix
@@ -1,13 +1,5 @@
-{ stdenv
-, sources
-, python3
-, cmake
-, pkgconfig
-, openmpi
-, cudaPackages
-}:
-let
- llama-python = python3.withPackages (ps: with ps; [ numpy sentencepiece ]);
+{ stdenv, sources, python3, cmake, pkgconfig, openmpi, cudaPackages }:
+let llama-python = python3.withPackages (ps: with ps; [ numpy sentencepiece ]);
in stdenv.mkDerivation {
name = "llama.cpp";
version = sources.llama-cpp.rev;