summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/outlines.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Bild/Deps/outlines.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Bild/Deps/outlines.nix')
-rw-r--r--Biz/Bild/Deps/outlines.nix23
1 files changed, 4 insertions, 19 deletions
diff --git a/Biz/Bild/Deps/outlines.nix b/Biz/Bild/Deps/outlines.nix
index 013581b..29ef41b 100644
--- a/Biz/Bild/Deps/outlines.nix
+++ b/Biz/Bild/Deps/outlines.nix
@@ -1,18 +1,5 @@
-{ lib
-, sources
-, buildPythonPackage
-, interegular
-, jinja2
-, lark
-, numpy
-, perscache
-, pillow
-, pydantic
-, regex
-, scipy
-, tenacity
-, torch
-}:
+{ lib, sources, buildPythonPackage, interegular, jinja2, lark, numpy, perscache
+, pillow, pydantic, regex, scipy, tenacity, torch }:
buildPythonPackage rec {
pname = "outlines";
@@ -35,10 +22,8 @@ buildPythonPackage rec {
torch
];
- doCheck = false; # no tests currently
- pythonImportsCheck = [
- "outlines"
- ];
+ doCheck = false; # no tests currently
+ pythonImportsCheck = [ "outlines" ];
meta = with lib; {
description = "Probabilistic Generative Model Programming";