summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/perscache.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/perscache.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/perscache.nix')
-rw-r--r--Biz/Bild/Deps/perscache.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/Biz/Bild/Deps/perscache.nix b/Biz/Bild/Deps/perscache.nix
deleted file mode 100644
index 508a261..0000000
--- a/Biz/Bild/Deps/perscache.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ lib, sources, buildPythonPackage, beartype, cloudpickle, icontract, pbr }:
-
-buildPythonPackage rec {
- pname = "perscache";
- version = sources.perscache.rev;
-
- src = sources.perscache;
-
- propagatedBuildInputs = [ beartype cloudpickle icontract pbr ];
- PBR_VERSION = version;
-
- doCheck = false; # no tests currently
- pythonImportsCheck = [ "perscache" ];
-
- meta = with lib; {
- description = ''
- An easy to use decorator for persistent memoization: like
- `functools.lrucache`, but results can be saved in any format to any
- storage.
- '';
- homepage = "https://github.com/leshchenko1979/perscache";
- license = licenses.mit;
- maintainers = with maintainers; [ bsima ];
- };
-}