summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/perscache.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Bild/Deps/perscache.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Bild/Deps/perscache.nix')
-rw-r--r--Biz/Bild/Deps/perscache.nix22
1 files changed, 4 insertions, 18 deletions
diff --git a/Biz/Bild/Deps/perscache.nix b/Biz/Bild/Deps/perscache.nix
index d757e1a..508a261 100644
--- a/Biz/Bild/Deps/perscache.nix
+++ b/Biz/Bild/Deps/perscache.nix
@@ -1,11 +1,4 @@
-{ lib
-, sources
-, buildPythonPackage
-, beartype
-, cloudpickle
-, icontract
-, pbr
-}:
+{ lib, sources, buildPythonPackage, beartype, cloudpickle, icontract, pbr }:
buildPythonPackage rec {
pname = "perscache";
@@ -13,18 +6,11 @@ buildPythonPackage rec {
src = sources.perscache;
- propagatedBuildInputs = [
- beartype
- cloudpickle
- icontract
- pbr
- ];
+ propagatedBuildInputs = [ beartype cloudpickle icontract pbr ];
PBR_VERSION = version;
- doCheck = false; # no tests currently
- pythonImportsCheck = [
- "perscache"
- ];
+ doCheck = false; # no tests currently
+ pythonImportsCheck = [ "perscache" ];
meta = with lib; {
description = ''