summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Comms/Mumble.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Cloud/Comms/Mumble.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Cloud/Comms/Mumble.nix')
-rw-r--r--Biz/Cloud/Comms/Mumble.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/Biz/Cloud/Comms/Mumble.nix b/Biz/Cloud/Comms/Mumble.nix
deleted file mode 100644
index 66d21a5..0000000
--- a/Biz/Cloud/Comms/Mumble.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ config, ... }:
-
-# mumble and related services
-let ports = import ../Ports.nix;
-in {
- services.murmur = {
- enable = true;
- openFirewall = true;
- environmentFile = "/var/lib/murmur/murmurd.env";
- registerHostname = config.networking.domain;
- registerName = config.networking.domain;
- };
-
- services.botamusique = {
- enable = true;
- settings = {
- webinterface = {
- enabled = true;
- listening_addr = "127.0.0.1";
- listening_port = ports.botamusique;
- };
- radio = { lofi = "https://live.hunter.fm/lofi_high"; };
- };
- };
-}