summaryrefslogtreecommitdiff
path: root/Biz/Dev/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Dev/Networking.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Dev/Networking.nix')
-rw-r--r--Biz/Dev/Networking.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/Biz/Dev/Networking.nix b/Biz/Dev/Networking.nix
deleted file mode 100644
index c89add7..0000000
--- a/Biz/Dev/Networking.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ ... }:
-
-let ports = import ../Cloud/Ports.nix;
-in {
- networking = {
- nameservers = [ "1.1.1.1" ];
- hostName = "lithium";
- hosts = { "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ]; };
-
- firewall = {
- allowedTCPPorts = [
- ports.bitcoind
- ports.bitcoind-rpc
- ports.delugeWeb
- ports.et
- ports.gemini
- ports.git
- ports.http
- ports.https
- ports.jellyfin
- ports.jupyter
- ports.k3s
- ports.mpd
- ports.mpd-stream
- ports.murmur
- ports.radicale
- ports.sabten
- ports.ssh
- ports.stableDiffusion
- ports.tor
- ];
- allowedTCPPortRanges = [ ports.torrents ports.httpdev ];
- allowedUDPPorts = [ ports.dns ports.et ports.murmur ];
- allowedUDPPortRanges = [ ports.torrents ];
- };
-
- # The global useDHCP flag is deprecated, therefore explicitly set to false here.
- # Per-interface useDHCP will be mandatory in the future, so this generated config
- # replicates the default behaviour.
- useDHCP = false;
- interfaces.enp2s0.useDHCP = true;
- };
-
-}