summaryrefslogtreecommitdiff
path: root/Biz/Dragons/Analysis.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Biz/Dragons/Analysis.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Biz/Dragons/Analysis.nix')
-rw-r--r--Biz/Dragons/Analysis.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/Biz/Dragons/Analysis.nix b/Biz/Dragons/Analysis.nix
index 9e59dee..1715610 100644
--- a/Biz/Dragons/Analysis.nix
+++ b/Biz/Dragons/Analysis.nix
@@ -1,17 +1,15 @@
-{ bild }:
-
+{bild}:
# Run this like so:
#
# bild Biz/Dragons/Analysis.nix
# docker load < _/nix/Biz/Dragons/Analysis.nix
# docker run --volume $PWD:/src dragons-analyze dragons-analyze /src/.git
-
bild.image {
name = "dragons-analyze";
tag = "latest";
fromImage = null;
fromImageName = null;
fromImageTag = "latest";
- contents = [ bild.pkgs.git (bild.run ./Analysis.hs) ];
- config.Cmd = [ "/bin/dragons-analyze" ];
+ contents = [bild.pkgs.git (bild.run ./Analysis.hs)];
+ config.Cmd = ["/bin/dragons-analyze"];
}