summaryrefslogtreecommitdiff
path: root/Biz/Dragons/Analysis.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-06 14:27:31 -0500
committerBen Sima <ben@bsima.me>2025-01-06 14:27:31 -0500
commitd9fb7a85c920c9332fba34087fe8527d140b65f0 (patch)
treeb99eac825214df8120db4f0e5143d7e1ac64a0e5 /Biz/Dragons/Analysis.nix
parent4a1ce4ecad5b4d41494f65887a7094685739e75b (diff)
Use x bit to identify buildable nix targets
This replaces the manually-curated nixTargets list in Bild.hs. Now any nix file that has the executable bit set will be built. I added run.sh shebangs to each of the buildable nix targets as well. When executing these, they will succeed at building, but they have no 'out' metadata, and so when run.sh tries to exec them, it will fail. This is fine for now. How would one go about execing a linux tree anyway? If all of the nix targets output something standard like a qemu image or a container, then I could have a standard wrapper that calls the image and starts the system. That might be the ideal way to have a runnable nix target. But this would require rethinking my infrastructure and how to deploy things, so I can't quite do that yet.
Diffstat (limited to 'Biz/Dragons/Analysis.nix')
-rwxr-xr-x[-rw-r--r--]Biz/Dragons/Analysis.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/Biz/Dragons/Analysis.nix b/Biz/Dragons/Analysis.nix
index 1715610..5ea8713 100644..100755
--- a/Biz/Dragons/Analysis.nix
+++ b/Biz/Dragons/Analysis.nix
@@ -1,3 +1,4 @@
+#!/usr/bin/env run.sh
{bild}:
# Run this like so:
#