summaryrefslogtreecommitdiff
path: root/Biz/Que/Host.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Biz/Que/Host.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Biz/Que/Host.nix')
-rw-r--r--Biz/Que/Host.nix16
1 files changed, 10 insertions, 6 deletions
diff --git a/Biz/Que/Host.nix b/Biz/Que/Host.nix
index b6b533e..5de94f5 100644
--- a/Biz/Que/Host.nix
+++ b/Biz/Que/Host.nix
@@ -1,6 +1,10 @@
-{ options, lib, config, ... }:
-
-let cfg = config.services.que-server;
+{
+ options,
+ lib,
+ config,
+ ...
+}: let
+ cfg = config.services.que-server;
in {
options.services.que-server = {
enable = lib.mkEnableOption "Enable the que-server service";
@@ -19,8 +23,8 @@ in {
};
config = lib.mkIf cfg.enable {
systemd.services.que-server = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
+ path = [cfg.package];
+ wantedBy = ["multi-user.target"];
script = ''
${cfg.package}/bin/que-server
'';
@@ -28,7 +32,7 @@ in {
Que server
'';
serviceConfig = {
- Environment = [ "QUE_PORT=${toString cfg.port}" ];
+ Environment = ["QUE_PORT=${toString cfg.port}"];
EnvironmentFile = "/run/que/env";
KillSignal = "INT";
Type = "simple";