summaryrefslogtreecommitdiff
path: root/Omni/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-02-06 17:40:53 -0500
committerBen Sima <ben@bsima.me>2025-02-06 17:40:53 -0500
commit1f9787cf112ebc82be6000c4bd1c09b7dc88c319 (patch)
tree2fdffaa8386d5f931e1b071fd6744ddc02d54a20 /Omni/Bild.nix
parent42d9c462002740a6a5cf8edb8fcfd00bcc36bb4b (diff)
Update nixpkgs and stupid fixes
Some things got through the CI system, probably during updates. So I had more stupid little fixes to do. I should really improve bild to the point that these won't happen anymore and builds don't take so long.
Diffstat (limited to 'Omni/Bild.nix')
-rw-r--r--Omni/Bild.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Omni/Bild.nix b/Omni/Bild.nix
index 95a7b40..8c1740f 100644
--- a/Omni/Bild.nix
+++ b/Omni/Bild.nix
@@ -280,14 +280,14 @@
};
# build an operating system. 'cfg' is the NixOS config
- os = cfg: (stable.nixos (_args: cfg)).toplevel;
+ os = cfg: (stable.nixos cfg).toplevel;
# build an os image for a digital ocean droplet
droplet = cfg:
(stable.nixos ({modulesPath, ...}: {
imports = [
"${toString modulesPath}/virtualisation/digital-ocean-image.nix"
- (_args: cfg)
+ cfg
];
}))
.digitalOceanImage;