summaryrefslogtreecommitdiff
path: root/Omni/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-31 13:48:05 -0500
committerBen Sima <ben@bsima.me>2024-12-31 13:48:05 -0500
commit3790d334c994db7a0e1eac9c130c2b1316c78c35 (patch)
treedf8bb9ecc6f1273864f8fc88082906526e0ab324 /Omni/Bild.nix
parent27904066fd204a2b844c27132e86f83acf217eed (diff)
Upgrade nixos 24.05 -> 24.11, ghc 9.4.8 -> 9.6.6
It's good to update, I think nixos 24.05 was deprecated anyway. The iPython dontCheck is because there was a test timeout; I don't even know why iPython is being pulled in but whatever.
Diffstat (limited to 'Omni/Bild.nix')
-rw-r--r--Omni/Bild.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Omni/Bild.nix b/Omni/Bild.nix
index a7c4e32..fdfa3b8 100644
--- a/Omni/Bild.nix
+++ b/Omni/Bild.nix
@@ -4,7 +4,7 @@ let
constants = import ./Bild/Constants.nix;
# expose some attrs from stable, keep this minimal and simple
- stable = let stable = nixpkgs.nixos-24_05;
+ stable = let stable = nixpkgs.nixos-24_11;
in {
inherit (stable)
sources lib makeWrapper ccacheStdenv haskell sbcl python312 nixos mkShell
@@ -142,7 +142,7 @@ let
buildPhase = ''
mkdir -p $out/bin $out/lib/ghc-$ghcVersion
cp -r \
- ${self.haskell.ghcPackageSetFull}/lib/ghc-$ghcVersion/package.conf.d \
+ ${self.haskell.ghcPackageSetFull}/lib/ghc-$ghcVersion/lib/package.conf.d \
$out/lib/ghc-$ghcVersion
ghc \
-threaded \