summaryrefslogtreecommitdiff
path: root/Omni/Bild/CcacheWrapper.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/CcacheWrapper.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/CcacheWrapper.nix')
-rw-r--r--Omni/Bild/CcacheWrapper.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/Omni/Bild/CcacheWrapper.nix b/Omni/Bild/CcacheWrapper.nix
index 644c2f6..26e6fc3 100644
--- a/Omni/Bild/CcacheWrapper.nix
+++ b/Omni/Bild/CcacheWrapper.nix
@@ -1,6 +1,4 @@
-self: super:
-
-let
+self: super: let
# this should come from config.programs.ccache.cacheDir but I can't figure out
# how to access that from a nixpkgs overlay, so just hardcode the default
ccacheDir = "/var/cache/ccache";
@@ -9,11 +7,13 @@ let
# deadnix: skip
fixwebkit = pkg:
self.useCcacheStdenv (pkg.overrideAttrs (attrs: rec {
- preConfigure = attrs.preConfigure + ''
- # not sure which of these works so just do them both
- export NUMBER_OF_PROCESSORS=$NIX_BUILD_CORES
- ninjaFlagsArray+=("-l$NIX_BUILD_CORES")
- '';
+ preConfigure =
+ attrs.preConfigure
+ + ''
+ # not sure which of these works so just do them both
+ export NUMBER_OF_PROCESSORS=$NIX_BUILD_CORES
+ ninjaFlagsArray+=("-l$NIX_BUILD_CORES")
+ '';
}));
in {
ccacheWrapper = super.ccacheWrapper.override {
@@ -42,7 +42,7 @@ in {
'';
};
- useCcacheStdenv = pkg: pkg.override { stdenv = super.ccacheStdenv; };
+ useCcacheStdenv = pkg: pkg.override {stdenv = super.ccacheStdenv;};
cudann = self.useCcacheStdenv super.cudann;
llvm = self.useCcacheStdenv super.llvm;