summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-02-04 21:18:03 -0500
committerBen Sima <ben@bsima.me>2025-02-04 21:18:03 -0500
commit9f5b334eb6d0f64460f14d76255b096777a46332 (patch)
treedb357ca2a933456e1f35c17a1c85000fb5a64b9d /Omni/Bild/Deps.nix
parent86ea51353c223cdc82cb8ebd013d58d70a7e646a (diff)
Update ollama, llm-ollama, openai-python, llm
I couldn't use llm-ollama because it required some package upgrades, so I started going down that rabbit hole and ended up 1) realizing that these packages are way out of date now, and 2) fiddling with overrides to get everything to work. I finally figured it out, the `postPatch` in ollama-python was throwing me off for like half a day. Anyway, one thing to note is that these are changing fast and I need to either move onto nixpkgs unstable for python stuff, or maintain my own builds of all of these. Not sure which is more appropriate right now. Oh and I had to fixup some logging stuff in Biz/Storybook.py because ruff started complaining about something, which is weird because I don't think the version changed? But it was easy enough to change.
Diffstat (limited to 'Omni/Bild/Deps.nix')
-rw-r--r--Omni/Bild/Deps.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/Omni/Bild/Deps.nix b/Omni/Bild/Deps.nix
index 0b23f9f..f25c947 100644
--- a/Omni/Bild/Deps.nix
+++ b/Omni/Bild/Deps.nix
@@ -24,11 +24,9 @@ _self: super: {
];
};
- llm = super.overrideSrc super.llm super.sources.llm;
-
nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix {};
- ollama = super.ollama.override {acceleration = "cuda";};
+ ollama = super.unstable.ollama.override {acceleration = "cuda";};
radicale = super.radicale.overrideAttrs (_old: {doCheck = false;});
}