summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/ludic.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/ludic.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/ludic.nix')
-rw-r--r--Omni/Bild/Deps/ludic.nix34
1 files changed, 23 insertions, 11 deletions
diff --git a/Omni/Bild/Deps/ludic.nix b/Omni/Bild/Deps/ludic.nix
index dfac06c..58936c7 100644
--- a/Omni/Bild/Deps/ludic.nix
+++ b/Omni/Bild/Deps/ludic.nix
@@ -1,7 +1,19 @@
-{ buildPythonPackage, fetchFromGitHub, lib, setuptools, pytestCheckHook
-, python-multipart, starlette, typeguard, pygments, pytest, pytest-cov, httpx
-, hatchling, hatch-vcs }:
-
+{
+ buildPythonPackage,
+ fetchFromGitHub,
+ lib,
+ setuptools,
+ pytestCheckHook,
+ python-multipart,
+ starlette,
+ typeguard,
+ pygments,
+ pytest,
+ pytest-cov,
+ httpx,
+ hatchling,
+ hatch-vcs,
+}:
buildPythonPackage rec {
pname = "ludic";
version = "0.5.2";
@@ -14,23 +26,23 @@ buildPythonPackage rec {
hash = "sha256-Zcob2ljyeiCqnCobkDP4ihRTxvs5OtQ4y5+Itsgs/0o=";
};
- nativeBuildInputs = [ setuptools hatchling hatch-vcs ];
+ nativeBuildInputs = [setuptools hatchling hatch-vcs];
- propagatedBuildInputs = [ python-multipart starlette typeguard pygments ];
+ propagatedBuildInputs = [python-multipart starlette typeguard pygments];
- disabledTestPaths = [ "tests/contrib/test_django.py" ];
+ disabledTestPaths = ["tests/contrib/test_django.py"];
- nativeCheckInputs = [ pytestCheckHook ];
+ nativeCheckInputs = [pytestCheckHook];
- checkInputs = [ pytest pytest-cov httpx ];
+ checkInputs = [pytest pytest-cov httpx];
- pythonImportsCheck = [ "ludic" ];
+ pythonImportsCheck = ["ludic"];
meta = with lib; {
homepage = "https://github.com/getludic/ludic";
description = "Web Development in Pure Python with Type-Guided Components.";
changelog = "https://github.com/getludic/ludic/releases/tag/${version}";
license = licenses.mit;
- maintainers = with maintainers; [ bsima ];
+ maintainers = with maintainers; [bsima];
};
}