summaryrefslogtreecommitdiff
path: root/Omni/Bild/Deps/nostr-rs-relay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Deps/nostr-rs-relay.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Deps/nostr-rs-relay.nix')
-rw-r--r--Omni/Bild/Deps/nostr-rs-relay.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/Omni/Bild/Deps/nostr-rs-relay.nix b/Omni/Bild/Deps/nostr-rs-relay.nix
index 0eef13f..df76cdd 100644
--- a/Omni/Bild/Deps/nostr-rs-relay.nix
+++ b/Omni/Bild/Deps/nostr-rs-relay.nix
@@ -1,5 +1,9 @@
-{ fetchFromSourcehut, rustPlatform, pkg-config, openssl }:
-
+{
+ fetchFromSourcehut,
+ rustPlatform,
+ pkg-config,
+ openssl,
+}:
rustPlatform.buildRustPackage rec {
pname = "nostr-rs-relay";
version = "0.7.15";
@@ -13,7 +17,7 @@ rustPlatform.buildRustPackage rec {
cargoSha256 = "sha256-3593pjc4A4NsEnE/ZYsR1vSMCvw2ZJue4EIY6cFa2WA=";
- nativeBuildInputs = [ pkg-config openssl.dev ];
+ nativeBuildInputs = [pkg-config openssl.dev];
- buildInputs = [ openssl.dev ];
+ buildInputs = [openssl.dev];
}