summaryrefslogtreecommitdiff
path: root/Omni/Bild/Haskell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Haskell.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Haskell.nix')
-rw-r--r--Omni/Bild/Haskell.nix61
1 files changed, 31 insertions, 30 deletions
diff --git a/Omni/Bild/Haskell.nix b/Omni/Bild/Haskell.nix
index 764ef5d..7e969da 100644
--- a/Omni/Bild/Haskell.nix
+++ b/Omni/Bild/Haskell.nix
@@ -1,37 +1,38 @@
-_self: super:
-
-let
+_self: super: let
inherit (import ./Constants.nix) ghcCompiler;
- buildCabal = sel: name: sel.callCabal2nix name super.sources.${name} { };
-
+ buildCabal = sel: name: sel.callCabal2nix name super.sources.${name} {};
in rec {
-
- haskell = super.haskell // {
- packages = super.haskell.packages // {
- "${ghcCompiler}" = super.haskell.packages."${ghcCompiler}".override
- (_old: {
- overrides = with super.pkgs.haskell.lib;
- sel: sup:
- super.overridePinnedDeps (buildCabal sel) // {
- ap-normalize = dontCheck sup.ap-normalize;
- clay = doJailbreak sup.clay;
- cmark = doJailbreak sup.cmark;
- docopt = buildCabal sel "docopt";
- filelock = dontCheck sup.filelock;
- linear-generics = doJailbreak sup.linear-generics;
- req = doJailbreak sup.req;
- servant-auth = doJailbreak sup.servant-auth;
- servant-auth-server = dontCheck sup.servant-auth-server;
- shellcheck = doJailbreak sup.shellcheck;
- string-qq = doJailbreak sup.string-qq;
- syb-with-class = doJailbreak sup.syb-with-class;
- th-abstraction = doJailbreak sup.th-abstraction;
- };
- });
+ haskell =
+ super.haskell
+ // {
+ packages =
+ super.haskell.packages
+ // {
+ "${ghcCompiler}" =
+ super.haskell.packages."${ghcCompiler}".override
+ (_old: {
+ overrides = with super.pkgs.haskell.lib;
+ sel: sup:
+ super.overridePinnedDeps (buildCabal sel)
+ // {
+ ap-normalize = dontCheck sup.ap-normalize;
+ clay = doJailbreak sup.clay;
+ cmark = doJailbreak sup.cmark;
+ docopt = buildCabal sel "docopt";
+ filelock = dontCheck sup.filelock;
+ linear-generics = doJailbreak sup.linear-generics;
+ req = doJailbreak sup.req;
+ servant-auth = doJailbreak sup.servant-auth;
+ servant-auth-server = dontCheck sup.servant-auth-server;
+ shellcheck = doJailbreak sup.shellcheck;
+ string-qq = doJailbreak sup.string-qq;
+ syb-with-class = doJailbreak sup.syb-with-class;
+ th-abstraction = doJailbreak sup.th-abstraction;
+ };
+ });
+ };
};
- };
ormolu = super.haskellPackages.ormolu;
-
}