summaryrefslogtreecommitdiff
path: root/Omni/Bild/Python.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bild/Python.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bild/Python.nix')
-rw-r--r--Omni/Bild/Python.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/Omni/Bild/Python.nix b/Omni/Bild/Python.nix
index 88abe94..035b11c 100644
--- a/Omni/Bild/Python.nix
+++ b/Omni/Bild/Python.nix
@@ -1,15 +1,15 @@
_self: super: {
python312 = super.python312.override {
packageOverrides = _pyself: pysuper:
- with pysuper.pkgs.python312Packages;
- let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
+ with pysuper.pkgs.python312Packages; let
+ dontCheck = p: p.overridePythonAttrs (_: {doCheck = false;});
in {
- interegular = callPackage ./Deps/interegular.nix { };
+ interegular = callPackage ./Deps/interegular.nix {};
ipython = dontCheck pysuper.ipython;
- ludic = callPackage ./Deps/ludic.nix { };
+ ludic = callPackage ./Deps/ludic.nix {};
mypy = dontCheck pysuper.mypy;
- outlines = callPackage ./Deps/outlines.nix { };
- perscache = callPackage ./Deps/perscache.nix { };
+ outlines = callPackage ./Deps/outlines.nix {};
+ perscache = callPackage ./Deps/perscache.nix {};
tokenizers = dontCheck pysuper.tokenizers;
};
};
@@ -17,9 +17,9 @@ _self: super: {
python311 = super.python311.override {
packageOverrides = _pyself: pysuper:
with pysuper.pkgs.python311Packages; {
- llm-ollama = callPackage ./Deps/llm-ollama.nix { };
+ llm-ollama = callPackage ./Deps/llm-ollama.nix {};
llm-sentence-transformers =
- callPackage ./Deps/llm-sentence-transformers.nix { };
+ callPackage ./Deps/llm-sentence-transformers.nix {};
};
};
}