summaryrefslogtreecommitdiff
path: root/Omni/Bot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Bot.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Bot.nix')
-rw-r--r--Omni/Bot.nix22
1 files changed, 13 insertions, 9 deletions
diff --git a/Omni/Bot.nix b/Omni/Bot.nix
index 934ad9c..d287e55 100644
--- a/Omni/Bot.nix
+++ b/Omni/Bot.nix
@@ -1,6 +1,11 @@
-{ options, lib, config, pkgs, ... }:
-
-let cfg = config.services.omnibot;
+{
+ options,
+ lib,
+ config,
+ pkgs,
+ ...
+}: let
+ cfg = config.services.omnibot;
in {
options.services.bizbot = {
enable = lib.mkEnableOption "Enable the omnibot service";
@@ -24,8 +29,8 @@ in {
config = lib.mkIf cfg.enable {
systemd.services = {
"omnibot-${cfg.server}-${cfg.channel}-ii" = {
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.ii ];
+ wantedBy = ["multi-user.target"];
+ path = [pkgs.ii];
script = ''
${pkgs.ii}/bin/ii ${cfg.dataDir}/irc -s ${cfg.server} -p 6667 -n omnibot
'';
@@ -35,12 +40,11 @@ in {
description = ''
omnibot ii tree for ${cfg.server}/${cfg.channel}
'';
-
};
"omnibot-${cfg.server}-${cfg.channel}" = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
- after = [ "omnibot-${cfg.server}-${cfg.channel}-ii.service" ];
+ path = [cfg.package];
+ wantedBy = ["multi-user.target"];
+ after = ["omnibot-${cfg.server}-${cfg.channel}-ii.service"];
script = ''
tail -f ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/out \
| ${cfg.package}/bin/omnibot \