summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Chat.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/Chat.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/Chat.nix')
-rw-r--r--Omni/Cloud/Chat.nix48
1 files changed, 28 insertions, 20 deletions
diff --git a/Omni/Cloud/Chat.nix b/Omni/Cloud/Chat.nix
index 7f86621..a3a6a78 100644
--- a/Omni/Cloud/Chat.nix
+++ b/Omni/Cloud/Chat.nix
@@ -1,4 +1,8 @@
-{ config, pkgs, ... }:
+{
+ config,
+ pkgs,
+ ...
+}:
#
# a homeserver for matrix.org.
#
@@ -24,17 +28,21 @@ in {
enable = false;
settings.server_name = config.networking.domain;
#registration_shared_secret = "AkGRWSQLga3RoKRFnHhKoeCEIeZzu31y4TRzMRkMyRbBnETkVTSxilf24qySLzQn";
- settings.listeners = [{
- port = matrix_port;
- bind_address = "::1";
- type = "http";
- tls = false;
- x_forwarded = true;
- resources = [{
- names = [ "client" "federation" ];
- compress = false;
- }];
- }];
+ settings.listeners = [
+ {
+ port = matrix_port;
+ bind_address = "::1";
+ type = "http";
+ tls = false;
+ x_forwarded = true;
+ resources = [
+ {
+ names = ["client" "federation"];
+ compress = false;
+ }
+ ];
+ }
+ ];
};
# matrix needs a database
#
@@ -50,16 +58,16 @@ in {
virtualHosts = {
# route to matrix-synapse
"${config.networking.domain}" = {
- locations."= /.well-known/matrix/server".extraConfig =
- let server = { "m.server" = "${fqdn}:443"; };
- in ''
- add_header Content-Type application/json;
- return 200 '${builtins.toJSON server}';
- '';
+ locations."= /.well-known/matrix/server".extraConfig = let
+ server = {"m.server" = "${fqdn}:443";};
+ in ''
+ add_header Content-Type application/json;
+ return 200 '${builtins.toJSON server}';
+ '';
locations."= /.well-known/matrix/client".extraConfig = let
client = {
- "m.homeserver" = { "base_url" = "https://${fqdn}"; };
- "m.identity_server" = { "base_url" = "https://vector.im"; };
+ "m.homeserver" = {"base_url" = "https://${fqdn}";};
+ "m.identity_server" = {"base_url" = "https://vector.im";};
};
in ''
add_header Content-Type application/json;