summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Comms/Xmpp.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/Comms/Xmpp.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/Comms/Xmpp.nix')
-rw-r--r--Omni/Cloud/Comms/Xmpp.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/Omni/Cloud/Comms/Xmpp.nix b/Omni/Cloud/Comms/Xmpp.nix
index ad8649b..5a8264b 100644
--- a/Omni/Cloud/Comms/Xmpp.nix
+++ b/Omni/Cloud/Comms/Xmpp.nix
@@ -1,4 +1,8 @@
-{ config, pkgs, ... }:
+{
+ config,
+ pkgs,
+ ...
+}:
#
# xmpp chat service
#
@@ -23,12 +27,12 @@ in {
services.prosody = {
enable = true;
package =
- pkgs.prosody.override { withCommunityModules = [ "conversejs" ]; };
+ pkgs.prosody.override {withCommunityModules = ["conversejs"];};
# when i learn how to use security.acme better, and use separate certs, then i
# can fix this group
group = "nginx";
- admins = [ "bsima@${rootDomain}" ];
+ admins = ["bsima@${rootDomain}"];
allowRegistration = true;
inherit ssl;
uploadHttp = {
@@ -126,7 +130,7 @@ in {
};
};
- services.prosody-filer = { enable = true; };
+ services.prosody-filer = {enable = true;};
services.nginx.virtualHosts."${rootDomain}".locations = {
"/http-bind" = {
@@ -186,7 +190,7 @@ in {
};
};
- users.users.nginx.extraGroups = [ "prosody" ];
+ users.users.nginx.extraGroups = ["prosody"];
security.acme.certs.${rootDomain}.extraDomainNames = [
# these stopped working idk why