summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
committerBen Sima <ben@bsima.me>2025-01-02 16:20:21 -0500
commit0fb4ae72c5754761fd7666e4274f4beef0484c32 (patch)
treed8820c808f31f287c3fcc266c02e3a26ddcdfbc3 /Omni/Cloud/Git.nix
parent3790d334c994db7a0e1eac9c130c2b1316c78c35 (diff)
Switch to alejandra for nix formatting
I mostly wanted a formatter that would format `inherit` blocks vertically, because otherwise they are super hard to read when diffing or even just editing. Both alejandra and the new nixos/nixfmt format verically like this, but alejandra has slightly better format (I guess) and for some reason nixfmt did not respect my `GLOBIGNORE` setting when doing `nixfmt **/*.nix` so it was trying to format stuff in `_/nix`, and failed. So anyway I went with alejandra. - https://github.com/kamadorueda/alejandra - https://discourse.nixos.org/t/enforcing-nix-formatting-in-nixpkgs/49506
Diffstat (limited to 'Omni/Cloud/Git.nix')
-rw-r--r--Omni/Cloud/Git.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/Omni/Cloud/Git.nix b/Omni/Cloud/Git.nix
index bc97d23..854c58a 100644
--- a/Omni/Cloud/Git.nix
+++ b/Omni/Cloud/Git.nix
@@ -1,6 +1,9 @@
-{ lib, config, pkgs, ... }:
-
-let
+{
+ lib,
+ config,
+ pkgs,
+ ...
+}: let
inherit (config.networking) domain;
root = "/var/git";
ports = import ./Ports.nix;
@@ -70,8 +73,7 @@ in {
];
plugins = [
(pkgs.fetchurl {
- url =
- "https://github.com/davido/gerrit-oauth-provider/releases/download/v3.5.1/gerrit-oauth-provider.jar";
+ url = "https://github.com/davido/gerrit-oauth-provider/releases/download/v3.5.1/gerrit-oauth-provider.jar";
sha256 = "sha256-MS3ElMRUrBX4miiflepMETRK3SaASqpqO3nUn9kq3Gk=";
})
];
@@ -80,16 +82,14 @@ in {
settings = {
auth.type = "OAUTH";
auth.gitBasicAuthPolicy = "HTTP";
- download.command = [ "checkout" "cherry_pick" "pull" "format_patch" ];
+ download.command = ["checkout" "cherry_pick" "pull" "format_patch"];
gerrit.canonicalWebUrl = "https://gerrit.${domain}";
- httpd.listenUrl =
- "proxy-https://${config.services.gerrit.listenAddress}";
+ httpd.listenUrl = "proxy-https://${config.services.gerrit.listenAddress}";
plugin.gerrit-oauth-provider-github-oauth = {
root-url = "https://github.com";
client-id = "e48084aa0eebe31a2b18";
};
- sshd.advertisedAddress =
- "gerrit.${domain}:${toString ports.gerrit-ssh}";
+ sshd.advertisedAddress = "gerrit.${domain}:${toString ports.gerrit-ssh}";
sshd.listenAddress = "[::]:${toString ports.gerrit-ssh}";
};
};
@@ -111,9 +111,9 @@ in {
group = "gitDaemon";
isSystemUser = true;
description = "Git daemon user";
- extraGroups = [ "git" ];
+ extraGroups = ["git"];
};
- "nginx".extraGroups = [ "git" ];
+ "nginx".extraGroups = ["git"];
};
- users.groups = { gitDaemon = { }; };
+ users.groups = {gitDaemon = {};};
}