summaryrefslogtreecommitdiff
path: root/Omni/Cloud/Git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2025-01-04 21:50:10 -0500
committerBen Sima <ben@bsima.me>2025-01-04 21:50:10 -0500
commit110edf2465856a2eff75b57ba4eb37b276b9b1c4 (patch)
treec839ab2d74a1aa56a4d85c106bbc91e4e58de6d2 /Omni/Cloud/Git.nix
parent380ae85ebad6d22c79b3cbb279e8d76e3427d5a5 (diff)
Disallow search engines from indexing my code, take 2
This was previously implemented in c467f7611f66b6d9b9dcb589ed534374cd7b2e6c but got lost when I updated nixos at some point. And then I noticed ClaudeBot was crawling my code while I was working on the previous commit. I don't really like that, so I'll just add this noindex and see if it stops.
Diffstat (limited to 'Omni/Cloud/Git.nix')
-rw-r--r--Omni/Cloud/Git.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/Omni/Cloud/Git.nix b/Omni/Cloud/Git.nix
index 50fe2c0..4d04b98 100644
--- a/Omni/Cloud/Git.nix
+++ b/Omni/Cloud/Git.nix
@@ -14,6 +14,9 @@ in {
nginx.virtualHosts."git.${domain}" = {
forceSSL = true;
useACMEHost = domain;
+ extraConfig = ''
+ add_header X-Robots-Tag "noindex, follow" always;
+ '';
};
cgit."git.${domain}" = {
enable = true;